Releases

Installation

  1. Backup Your World!
  2. Delete any old versions of the Railcraft jar files in the "<minecraft>/mods" folder
  3. Install Minecraft Forge (see downloads for compatible versions)
  4. Download and drop the Railcraft jar file into the "<minecraft>/mods" folder.
  5. Do not extract or attempt to place the contents into minecraft.jar!
Note:
Railcraft is split into a number of different functional modules, these modules can be enabled/disabled via the modules.cfg file in the railcraft config folder.

Mods that work well with Railcraft


(this is an advertisement)

Current Version

Railcraft Version: 9.10.0.0
Minecraft Version: 1.7.10
Forge Versions: 10.13.0.1199+
Release Date: March 22, 2016, 4:40 pm
Railcraft API: 9.10.0.0-api Download API (for modders only)
Dev Build: 9.10.0.0-dev Download Dev Build (for modders only)
Download Railcraft 9.10.0.0 Here
Mirror 1 Mirror 2
Download via Adf.ly / CurseForge Download via CurseForge
By downloading this file, you are agreeing to terms in the license posted here.

Change Log:

  • NEW: Added Auto-Coupler Mode to Coupler Track. Any cart that passes over this track will couple to the next cart it collides with. (contribution by Cream-tea)
  • NEW: Add support for IC2 Classic. (contribution by Speiger)
  • CHANGE: Reworked harvest tools for the entire mod. Tracks and related blocks are by default harvestable by the crowbar instead of pickaxes. Other blocks are either axe or pickaxe depending on material.
  • FIX: Signals and Boxes now use a TESR for rendering the lights, resulting in less render refreshes. (contribution by Vexatos and Player)
  • FIX: Fix OreDict tag in Tin Plate recipe. (issue #781)
  • FIX: Fix issues with server/client sync of filtered Carts.
  • FIX: Only cache Tile Entities located in the same chunk as the cache. Should resolve untold issues with Signals and Multi-Blocks.
  • FIX: Improve High Speed explosion logic to take into account the comparison of Train objects. Might result in less unpredictable explosions.
  • FIX: Fixed NPE in Anchor Chunkloader code caused by mismatched worlds.
  • API: SignalBlock was moved to the API so that addons can create new Signal blocks.

Donate

If you would like to support the continued development of Railcraft,
please donate via Patreon.

- OR PayPal -
As a thank you, anyone who donates $10 or more can fill out this form if they would like direct access to Railcraft Releases and Betas and the #railcraft-dev IRC channel.

(this is an advertisement)

Old Versions

Railcraft Version Minecraft Version Forge Version
9.10.0.0 1.7.10 10.13.0.1199+
9.9.0.0 1.7.10 10.13.0.1199+
9.8.0.0 1.7.10 10.13.0.1199+
9.7.0.0 1.7.10 10.13.0.1199+
9.6.1.0 1.7.10 10.13.0.1199+
9.6.0.0 1.7.10 10.13.0.1199+
9.5.0.0 1.7.10 10.13.0.1199+
9.4.0.0 1.7.10 10.13.0.1199+
9.3.3.0 1.7.10 10.13.0.1199+
9.3.2.0 1.7.10 10.13.0.1199+
9.3.1.0 1.7.10 10.13.0.1199+
9.3.0.0 1.7.10 10.13.0.1199+
9.2.2.0 1.7.10 10.13.0.1199+
9.2.1.0 1.7.10 10.13.0.1199+
9.2.0.0 1.7.10 10.13.0.1182+
9.1.0.0 1.7.2 10.12.1.1065+
9.0.0.0 1.7.2 10.12.1.1065+
8.4.0.0 1.6.4 9.11.1.965
8.3.2.0 1.6.4 9.11.1.965+
8.3.1.0 1.6.4 9.11.1.953
8.3.0.0 1.6.4 9.11.1.953
8.2.0.0 1.6.2-1.6.4 9.10.1.867+
8.1.0.0 1.6.2-1.6.4 9.10.1.867+
8.0.2.0 1.6.2 9.10.0.818+
8.0.1.0 1.6.2 9.10.0.818+
8.0.0.0 1.6.2 9.10.0.818+
7.3.0.0 1.5.1-1.5.2 7.7.1.624+
7.2.3.0 1.5.1-1.5.2 7.7.1.624+
7.2.2.0 1.5.1-1.5.2 7.7.1.624+
7.2.1.0 1.5.1-1.5.2 7.7.1.624+
7.2.0.0 1.5.1-1.5.2 7.7.1.624+
7.1.0.0 1.5.1 7.7.1.624+
7.0.0.0 1.5.1 7.7.1.624+
6.17.0.0 1.4.7 6.6.0.516+
6.16.0.0 1.4.7 6.6.0.516+
6.15.3.0 1.4.7 6.6.0.516+
6.15.2.0 1.4.7 6.6.0.516+

Adf.ly Referral


Get paid to share your links! - (this ad is not affliated with Google Adsense)